import Foundation
let pattern = #"^(.*)\/Links\/(?<artFileName>.+?)(?:_r(?<revisionNumber>\d+))?\.(?<extension>pdf)$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
Blah/Blah/Obam_9781524763138_die_all_r1 Folder/Links/Obam_9781524763138_die_all_r1.pdf
Blah/Blah/Obam_9781524763138_die_all_r1 Folder/Links/Obam_9781524763138_die_all.pdf
Blah/Blah/Obam_9781524763138_die_all_r1 Folder/Links/apple.pdf
Blah/Blah/Obam_9781524763138_die_all_r1 Folder/Links/apple_r1.pdf
Blah/Blah/Obam_9781524763138_die_all_r1 Folder/Links/001_apple_r1.pdf
Blah/Blah/Obam_9781524763138_die_all_r1 Folder/Links/001_apple.pdf
Blah/Blah/Obam_9781524763138_die_all_r1 Folder/Links/.pdf
Blah/Blah/Obam_9781524763138_die_all_r1 Folder/Links/r1.pdf
Blah/Blah/Obam_9781524763138_die_all_r1 Folder/Links/.pdf
Blah/Blah/Obam_9781524763138_die_all_r1 Folder/Links/_r1.pdf
Blah/Blah/Obam_9781524763138_die_all_r1 Folder/Links/001.pdf
Blah/Blah/Obam_9781524763138_die_all_r1 Folder/Links/001_r1.pdf
Blah/Blah/Obam_9781524763138_die_all_r1 Folder/Links/001r1.pdf
Blah/Blah/Obam_9781524763138_die_all_r1 Folder/Links/apple.orange
Blah/Blah/Obam_9781524763138_die_all_r1 Folder/Links/apple
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)