# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(.*)\/Links\/(?<artFileName>.+?)(?:_r(?<revisionNumber>\d+))?\.(?<extension>pdf)$"
test_str = ("Blah/Blah/Obam_9781524763138_die_all_r1 Folder/Links/Obam_9781524763138_die_all_r1.pdf\n"
"Blah/Blah/Obam_9781524763138_die_all_r1 Folder/Links/Obam_9781524763138_die_all.pdf\n"
"Blah/Blah/Obam_9781524763138_die_all_r1 Folder/Links/apple.pdf\n"
"Blah/Blah/Obam_9781524763138_die_all_r1 Folder/Links/apple_r1.pdf\n"
"Blah/Blah/Obam_9781524763138_die_all_r1 Folder/Links/001_apple_r1.pdf\n"
"Blah/Blah/Obam_9781524763138_die_all_r1 Folder/Links/001_apple.pdf\n"
"Blah/Blah/Obam_9781524763138_die_all_r1 Folder/Links/.pdf\n"
"Blah/Blah/Obam_9781524763138_die_all_r1 Folder/Links/r1.pdf\n"
"Blah/Blah/Obam_9781524763138_die_all_r1 Folder/Links/.pdf\n"
"Blah/Blah/Obam_9781524763138_die_all_r1 Folder/Links/_r1.pdf\n"
"Blah/Blah/Obam_9781524763138_die_all_r1 Folder/Links/001.pdf\n"
"Blah/Blah/Obam_9781524763138_die_all_r1 Folder/Links/001_r1.pdf\n"
"Blah/Blah/Obam_9781524763138_die_all_r1 Folder/Links/001r1.pdf\n"
"Blah/Blah/Obam_9781524763138_die_all_r1 Folder/Links/apple.orange\n"
"Blah/Blah/Obam_9781524763138_die_all_r1 Folder/Links/apple\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.