#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(.*)\/Links\/(?<artFileName>.+?)(?:_r(?<revisionNumber>\d+))?\.(?<extension>pdf)$"
Local $sString = "Blah/Blah/Obam_9781524763138_die_all_r1 Folder/Links/Obam_9781524763138_die_all_r1.pdf" & @CRLF & _
"Blah/Blah/Obam_9781524763138_die_all_r1 Folder/Links/Obam_9781524763138_die_all.pdf" & @CRLF & _
"Blah/Blah/Obam_9781524763138_die_all_r1 Folder/Links/apple.pdf" & @CRLF & _
"Blah/Blah/Obam_9781524763138_die_all_r1 Folder/Links/apple_r1.pdf" & @CRLF & _
"Blah/Blah/Obam_9781524763138_die_all_r1 Folder/Links/001_apple_r1.pdf" & @CRLF & _
"Blah/Blah/Obam_9781524763138_die_all_r1 Folder/Links/001_apple.pdf" & @CRLF & _
"Blah/Blah/Obam_9781524763138_die_all_r1 Folder/Links/.pdf" & @CRLF & _
"Blah/Blah/Obam_9781524763138_die_all_r1 Folder/Links/r1.pdf" & @CRLF & _
"Blah/Blah/Obam_9781524763138_die_all_r1 Folder/Links/.pdf" & @CRLF & _
"Blah/Blah/Obam_9781524763138_die_all_r1 Folder/Links/_r1.pdf" & @CRLF & _
"Blah/Blah/Obam_9781524763138_die_all_r1 Folder/Links/001.pdf" & @CRLF & _
"Blah/Blah/Obam_9781524763138_die_all_r1 Folder/Links/001_r1.pdf" & @CRLF & _
"Blah/Blah/Obam_9781524763138_die_all_r1 Folder/Links/001r1.pdf" & @CRLF & _
"Blah/Blah/Obam_9781524763138_die_all_r1 Folder/Links/apple.orange" & @CRLF & _
"Blah/Blah/Obam_9781524763138_die_all_r1 Folder/Links/apple" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")