import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(.*)\\/Links\\/(?<artFileName>.+?)(?:_r(?<revisionNumber>\\d+))?\\.(?<extension>pdf)$";
final String string = "Blah/Blah/Obam_9781524763138_die_all_r1 Folder/Links/Obam_9781524763138_die_all_r1.pdf\n"
+ "Blah/Blah/Obam_9781524763138_die_all_r1 Folder/Links/Obam_9781524763138_die_all.pdf\n"
+ "Blah/Blah/Obam_9781524763138_die_all_r1 Folder/Links/apple.pdf\n"
+ "Blah/Blah/Obam_9781524763138_die_all_r1 Folder/Links/apple_r1.pdf\n"
+ "Blah/Blah/Obam_9781524763138_die_all_r1 Folder/Links/001_apple_r1.pdf\n"
+ "Blah/Blah/Obam_9781524763138_die_all_r1 Folder/Links/001_apple.pdf\n"
+ "Blah/Blah/Obam_9781524763138_die_all_r1 Folder/Links/.pdf\n"
+ "Blah/Blah/Obam_9781524763138_die_all_r1 Folder/Links/r1.pdf\n"
+ "Blah/Blah/Obam_9781524763138_die_all_r1 Folder/Links/.pdf\n"
+ "Blah/Blah/Obam_9781524763138_die_all_r1 Folder/Links/_r1.pdf\n"
+ "Blah/Blah/Obam_9781524763138_die_all_r1 Folder/Links/001.pdf\n"
+ "Blah/Blah/Obam_9781524763138_die_all_r1 Folder/Links/001_r1.pdf\n"
+ "Blah/Blah/Obam_9781524763138_die_all_r1 Folder/Links/001r1.pdf\n"
+ "Blah/Blah/Obam_9781524763138_die_all_r1 Folder/Links/apple.orange\n"
+ "Blah/Blah/Obam_9781524763138_die_all_r1 Folder/Links/apple\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}