// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(.*)\/Links\/(?<artFileName>.+?)(?:_r(?<revisionNumber>\d+))?\.(?<extension>pdf)$").unwrap();
let string = "Blah/Blah/Obam_9781524763138_die_all_r1 Folder/Links/Obam_9781524763138_die_all_r1.pdf
Blah/Blah/Obam_9781524763138_die_all_r1 Folder/Links/Obam_9781524763138_die_all.pdf
Blah/Blah/Obam_9781524763138_die_all_r1 Folder/Links/apple.pdf
Blah/Blah/Obam_9781524763138_die_all_r1 Folder/Links/apple_r1.pdf
Blah/Blah/Obam_9781524763138_die_all_r1 Folder/Links/001_apple_r1.pdf
Blah/Blah/Obam_9781524763138_die_all_r1 Folder/Links/001_apple.pdf
Blah/Blah/Obam_9781524763138_die_all_r1 Folder/Links/.pdf
Blah/Blah/Obam_9781524763138_die_all_r1 Folder/Links/r1.pdf
Blah/Blah/Obam_9781524763138_die_all_r1 Folder/Links/.pdf
Blah/Blah/Obam_9781524763138_die_all_r1 Folder/Links/_r1.pdf
Blah/Blah/Obam_9781524763138_die_all_r1 Folder/Links/001.pdf
Blah/Blah/Obam_9781524763138_die_all_r1 Folder/Links/001_r1.pdf
Blah/Blah/Obam_9781524763138_die_all_r1 Folder/Links/001r1.pdf
Blah/Blah/Obam_9781524763138_die_all_r1 Folder/Links/apple.orange
Blah/Blah/Obam_9781524763138_die_all_r1 Folder/Links/apple
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}