re = /^(.*)\/Links\/(?<artFileName>.+?)(?:_r(?<revisionNumber>\d+))?\.(?<extension>pdf)$/m
str = 'Blah/Blah/Obam_9781524763138_die_all_r1 Folder/Links/Obam_9781524763138_die_all_r1.pdf
Blah/Blah/Obam_9781524763138_die_all_r1 Folder/Links/Obam_9781524763138_die_all.pdf
Blah/Blah/Obam_9781524763138_die_all_r1 Folder/Links/apple.pdf
Blah/Blah/Obam_9781524763138_die_all_r1 Folder/Links/apple_r1.pdf
Blah/Blah/Obam_9781524763138_die_all_r1 Folder/Links/001_apple_r1.pdf
Blah/Blah/Obam_9781524763138_die_all_r1 Folder/Links/001_apple.pdf
Blah/Blah/Obam_9781524763138_die_all_r1 Folder/Links/.pdf
Blah/Blah/Obam_9781524763138_die_all_r1 Folder/Links/r1.pdf
Blah/Blah/Obam_9781524763138_die_all_r1 Folder/Links/.pdf
Blah/Blah/Obam_9781524763138_die_all_r1 Folder/Links/_r1.pdf
Blah/Blah/Obam_9781524763138_die_all_r1 Folder/Links/001.pdf
Blah/Blah/Obam_9781524763138_die_all_r1 Folder/Links/001_r1.pdf
Blah/Blah/Obam_9781524763138_die_all_r1 Folder/Links/001r1.pdf
Blah/Blah/Obam_9781524763138_die_all_r1 Folder/Links/apple.orange
Blah/Blah/Obam_9781524763138_die_all_r1 Folder/Links/apple
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end