const regex = /^(.*)\/Links\/(?<artFileName>.+?)(?:_r(?<revisionNumber>\d+))?\.(?<extension>pdf)$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(.*)\\\/Links\\\/(?<artFileName>.+?)(?:_r(?<revisionNumber>\\d+))?\\.(?<extension>pdf)$', 'gm')
const str = `Blah/Blah/Obam_9781524763138_die_all_r1 Folder/Links/Obam_9781524763138_die_all_r1.pdf
Blah/Blah/Obam_9781524763138_die_all_r1 Folder/Links/Obam_9781524763138_die_all.pdf
Blah/Blah/Obam_9781524763138_die_all_r1 Folder/Links/apple.pdf
Blah/Blah/Obam_9781524763138_die_all_r1 Folder/Links/apple_r1.pdf
Blah/Blah/Obam_9781524763138_die_all_r1 Folder/Links/001_apple_r1.pdf
Blah/Blah/Obam_9781524763138_die_all_r1 Folder/Links/001_apple.pdf
Blah/Blah/Obam_9781524763138_die_all_r1 Folder/Links/.pdf
Blah/Blah/Obam_9781524763138_die_all_r1 Folder/Links/r1.pdf
Blah/Blah/Obam_9781524763138_die_all_r1 Folder/Links/.pdf
Blah/Blah/Obam_9781524763138_die_all_r1 Folder/Links/_r1.pdf
Blah/Blah/Obam_9781524763138_die_all_r1 Folder/Links/001.pdf
Blah/Blah/Obam_9781524763138_die_all_r1 Folder/Links/001_r1.pdf
Blah/Blah/Obam_9781524763138_die_all_r1 Folder/Links/001r1.pdf
Blah/Blah/Obam_9781524763138_die_all_r1 Folder/Links/apple.orange
Blah/Blah/Obam_9781524763138_die_all_r1 Folder/Links/apple
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}