// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)<[^>]*>").unwrap();
let string = "[</w:t></w:r><w:r w:rsidR=\"00042557\"><w:t>ИмяПоля3</w:t></w:r><w:r w:rsidR=\"00042557\" w:rsidRPr=\"004C3B57\"><w:t>]";
let substitution = "";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}