# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/<[^>]*>//gm;t' <<< "[</w:t></w:r><w:r w:rsidR=\"00042557\"><w:t>ИмяПоля3</w:t></w:r><w:r w:rsidR=\"00042557\" w:rsidRPr=\"004C3B57\"><w:t>]"