const regex = /<[^>]*>/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<[^>]*>', 'gm')
const str = `[</w:t></w:r><w:r w:rsidR="00042557"><w:t>ИмяПоля3</w:t></w:r><w:r w:rsidR="00042557" w:rsidRPr="004C3B57"><w:t>]`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);