$re = '/<[^>]*>/m';
$str = '[</w:t></w:r><w:r w:rsidR="00042557"><w:t>ИмяПоля3</w:t></w:r><w:r w:rsidR="00042557" w:rsidRPr="004C3B57"><w:t>]';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;