package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)<[^>]*>`)
var str = `[</w:t></w:r><w:r w:rsidR="00042557"><w:t>ИмяПоля3</w:t></w:r><w:r w:rsidR="00042557" w:rsidRPr="004C3B57"><w:t>]`
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}