using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<[^>]*>";
string substitution = @"";
string input = @"[</w:t></w:r><w:r w:rsidR=""00042557""><w:t>ИмяПоля3</w:t></w:r><w:r w:rsidR=""00042557"" w:rsidRPr=""004C3B57""><w:t>]";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}