import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<[^>]*>";
final String string = "[</w:t></w:r><w:r w:rsidR=\"00042557\"><w:t>ИмяПоля3</w:t></w:r><w:r w:rsidR=\"00042557\" w:rsidRPr=\"004C3B57\"><w:t>]";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}