import Foundation
let pattern = #"file_path:\s*\"([^\"]+)\",\s*text:\s*\"([^\"]+)\""#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
file_path: "hello_world.txt", text: "Hello World"
"file_path": "hello_universe.txt", "text": "Hello Universe"
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}