package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`file_path:\s*\"([^\"]+)\",\s*text:\s*\"([^\"]+)\"`)
var str = `file_path: "hello_world.txt", text: "Hello World"
"file_path": "hello_universe.txt", "text": "Hello Universe"`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}