const regex = new RegExp('file_path:\\s*\\"([^\\"]+)\\",\\s*text:\\s*\\"([^\\"]+)\\"', '')
const str = `file_path: "hello_world.txt", text: "Hello World"
"file_path": "hello_universe.txt", "text": "Hello Universe"`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}