using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"file_path:\s*\""([^\""]+)\"",\s*text:\s*\""([^\""]+)\""";
string input = @"file_path: ""hello_world.txt"", text: ""Hello World""
""file_path"": ""hello_universe.txt"", ""text"": ""Hello Universe""";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}