#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "file_path:\s*\"([^\"]+)\",\s*text:\s*\"([^\"]+)\""
Local $sString = "file_path: "hello_world.txt", text: "Hello World"" & @CRLF & _
""file_path": "hello_universe.txt", "text": "Hello Universe""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")