$re = '/file_path:\s*\"([^\"]+)\",\s*text:\s*\"([^\"]+)\"/';
$str = 'file_path: "hello_world.txt", text: "Hello World"
"file_path": "hello_universe.txt", "text": "Hello Universe"';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);