// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"file_path:\s*\"([^\"]+)\",\s*text:\s*\"([^\"]+)\""#).unwrap();
let string = "file_path: \"hello_world.txt\", text: \"Hello World\"
\"file_path\": \"hello_universe.txt\", \"text\": \"Hello Universe\"";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}