re = /file_path:\s*\"([^\"]+)\",\s*text:\s*\"([^\"]+)\"/
str = 'file_path: "hello_world.txt", text: "Hello World"
"file_path": "hello_universe.txt", "text": "Hello Universe"'
# Print the match result
str.match(re) do |match|
puts match.to_s
end