import Foundation
let pattern = #"(\w*[aeiou][aeiou][aeiou]\w*)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
Life is beautiful
Obviously, the queen is courageous and gracious.
The rambunctious children had to sit quietly and await their delicious dinner.
The order of a data queue is First In First Out (FIFO)
Hello world!
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""\1+1-\2\3""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)