using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\w*[aeiou][aeiou][aeiou]\w*)";
string substitution = @"""\1+1-\2\3""";
string input = @"Life is beautiful
Obviously, the queen is courageous and gracious.
The rambunctious children had to sit quietly and await their delicious dinner.
The order of a data queue is First In First Out (FIFO)
Hello world!
";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}