package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(\w*[aeiou][aeiou][aeiou]\w*)`)
var str = `Life is beautiful
Obviously, the queen is courageous and gracious.
The rambunctious children had to sit quietly and await their delicious dinner.
The order of a data queue is First In First Out (FIFO)
Hello world!
`
var substitution = ""\1+1-\2\3""
fmt.Println(re.ReplaceAllString(str, substitution))
}