import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\w*[aeiou][aeiou][aeiou]\\w*)";
final String string = "Life is beautiful\n"
+ "Obviously, the queen is courageous and gracious.\n"
+ "The rambunctious children had to sit quietly and await their delicious dinner.\n"
+ "The order of a data queue is First In First Out (FIFO)\n"
+ "Hello world!\n";
final String subst = "\"\\1+1-\\2\\3\"";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}