// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)product\/[0-9]+\/[0-9]+$").unwrap();
let string = "product/333/2
productx
product/342342/332
product/xk
produt/13k
product//
product/23/
product/23/xx
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}