$re = '/product\/[0-9]+\/[0-9]+$/m';
$str = 'product/333/2
productx
product/342342/332
product/xk
produt/13k
product//
product/23/
product/23/xx
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);