package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)product\/[0-9]+\/[0-9]+$`)
var str = `product/333/2
productx
product/342342/332
product/xk
produt/13k
product//
product/23/
product/23/xx
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}