re = /product\/[0-9]+\/[0-9]+$/m
str = 'product/333/2
productx
product/342342/332
product/xk
produt/13k
product//
product/23/
product/23/xx
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end