const regex = /product\/[0-9]+\/[0-9]+$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('product\\\/[0-9]+\\\/[0-9]+$', 'gm')
const str = `product/333/2
productx
product/342342/332
product/xk
produt/13k
product//
product/23/
product/23/xx
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}