using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"product\/[0-9]+\/[0-9]+$";
string input = @"product/333/2
productx
product/342342/332
product/xk
produt/13k
product//
product/23/
product/23/xx
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}