import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "product\\/[0-9]+\\/[0-9]+$";
final String string = "product/333/2\n"
+ "productx\n"
+ "product/342342/332\n"
+ "product/xk\n"
+ "produt/13k\n"
+ "product//\n"
+ "product/23/\n"
+ "product/23/xx\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}