#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)product\/[0-9]+\/[0-9]+$"
Local $sString = "product/333/2" & @CRLF & _
"productx" & @CRLF & _
"product/342342/332" & @CRLF & _
"product/xk" & @CRLF & _
"produt/13k" & @CRLF & _
"product//" & @CRLF & _
"product/23/" & @CRLF & _
"product/23/xx" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")