re = /(<title><\?php echo L10n::message\('label.edit')(.*?)(<\/title>)/m
str = '<title><?php echo L10n::message(\'label.edit\', L10n::label(\'location\')); ?></title>
<title><?php echo L10n::message(\'label.edit\', L10n::label(\'manufacturer\', rrue)); ?></title>
<title><?php echo L10n::message(\'label.edit\', L10n::label(\'items.de\')); ?></title>
<title><?php echo L10n::message(\'label.edit\', L10n::label(\'water_as\')); ?></title>'
subst = '<title><?php echo L10n::label(\'edit\'); ?></title>'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result