using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(<title><\?php echo L10n::message\('label.edit')(.*?)(<\/title>)";
string substitution = @"<title><?php echo L10n::label('edit'); ?></title>";
string input = @"<title><?php echo L10n::message('label.edit', L10n::label('location')); ?></title>
<title><?php echo L10n::message('label.edit', L10n::label('manufacturer', rrue)); ?></title>
<title><?php echo L10n::message('label.edit', L10n::label('items.de')); ?></title>
<title><?php echo L10n::message('label.edit', L10n::label('water_as')); ?></title>";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}