use strict;
my $str = '<title><?php echo L10n::message(\'label.edit\', L10n::label(\'location\')); ?></title>
<title><?php echo L10n::message(\'label.edit\', L10n::label(\'manufacturer\', rrue)); ?></title>
<title><?php echo L10n::message(\'label.edit\', L10n::label(\'items.de\')); ?></title>
<title><?php echo L10n::message(\'label.edit\', L10n::label(\'water_as\')); ?></title>';
my $regex = qr/(<title><\?php echo L10n::message\('label.edit')(.*?)(<\/title>)/mp;
my $subst = '<title><?php echo L10n::label(\'edit\'); ?></title>';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";