# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(<title><\?php echo L10n::message\('label.edit')(.*?)(<\/title>)"
test_str = ("<title><?php echo L10n::message('label.edit', L10n::label('location')); ?></title>\n"
"<title><?php echo L10n::message('label.edit', L10n::label('manufacturer', rrue)); ?></title>\n"
"<title><?php echo L10n::message('label.edit', L10n::label('items.de')); ?></title>\n"
"<title><?php echo L10n::message('label.edit', L10n::label('water_as')); ?></title>")
subst = "<title><?php echo L10n::label('edit'); ?></title>"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.