import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(<title><\\?php echo L10n::message\\('label.edit')(.*?)(<\\/title>)";
final String string = "<title><?php echo L10n::message('label.edit', L10n::label('location')); ?></title>\n"
+ "<title><?php echo L10n::message('label.edit', L10n::label('manufacturer', rrue)); ?></title>\n"
+ "<title><?php echo L10n::message('label.edit', L10n::label('items.de')); ?></title>\n"
+ "<title><?php echo L10n::message('label.edit', L10n::label('water_as')); ?></title>";
final String subst = "<title><?php echo L10n::label('edit'); ?></title>";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}