import Foundation
let pattern = #"(\w)(\w+)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
any word whatsoever
ANY WORD WHATSOEVER
aNy WoRd WhAtSoEvEr
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\U$1\E\L$2"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)