const regex = /(\w)(\w+)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\w)(\\w+)', 'gm')
const str = `any word whatsoever
ANY WORD WHATSOEVER
aNy WoRd WhAtSoEvEr`;
const subst = `\U$1\E\L$2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);