re = /(\w)(\w+)/m
str = 'any word whatsoever
ANY WORD WHATSOEVER
aNy WoRd WhAtSoEvEr'
subst = '\\U$1\\E\\L$2'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result