# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(\w)(\w+)/\U$1\E\L$2/gm;t' <<< "any word whatsoever
ANY WORD WHATSOEVER
aNy WoRd WhAtSoEvEr"