use strict;
my $str = 'any word whatsoever
ANY WORD WHATSOEVER
aNy WoRd WhAtSoEvEr';
my $regex = qr/(\w)(\w+)/mp;
my $subst = '\\U$1\\E\\L$2';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";