#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(\w)(\w+)"
Local $sString = "any word whatsoever" & @CRLF & _
"ANY WORD WHATSOEVER" & @CRLF & _
"aNy WoRd WhAtSoEvEr"
Local $sSubst = "\U$1\E\L$2"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)