import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\w)(\\w+)";
final String string = "any word whatsoever\n"
+ "ANY WORD WHATSOEVER\n"
+ "aNy WoRd WhAtSoEvEr";
final String subst = "\\U$1\\E\\L$2";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}