using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\w)(\w+)";
string substitution = @"\U$1\E\L$2";
string input = @"any word whatsoever
ANY WORD WHATSOEVER
aNy WoRd WhAtSoEvEr";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}