// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?i)\d*\.?,?\d+|[\*\-\+\/\(\)\$]").unwrap();
let string = "$( 10 * 10.65 ) - 30
$(10*10,65)-(30+2)
$(10*10.0)-30
(10*10.0)-30
10 10.65 * $ 30 -
100 + 1
1 + 1
1 1 +
8 + 8 / 4";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}