using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\d*\.?,?\d+|[\*\-\+\/\(\)\$]";
string input = @"$( 10 * 10.65 ) - 30
$(10*10,65)-(30+2)
$(10*10.0)-30
(10*10.0)-30
10 10.65 * $ 30 -
100 + 1
1 + 1
1 1 +
8 + 8 / 4";
RegexOptions options = RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}