#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?i)\d*\.?,?\d+|[\*\-\+\/\(\)\$]"
Local $sString = "$( 10 * 10.65 ) - 30" & @CRLF & _
"$(10*10,65)-(30+2)" & @CRLF & _
"$(10*10.0)-30" & @CRLF & _
"(10*10.0)-30" & @CRLF & _
"10 10.65 * $ 30 -" & @CRLF & _
"100 + 1" & @CRLF & _
"1 + 1" & @CRLF & _
"1 1 +" & @CRLF & _
"8 + 8 / 4"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")